Due to the Mac Pro 1,1 EFI being 32bit you will need to use a tool to remove the EFI functions from the installer.
This tool worked great for creating an ISO. Use the MBR boot loader during install. Be sure to install src and ports pkg.
There are a few things you have to configure to get it to work properly.
Packages/src/ports (Security)
Change the word quarterly to latest in /etc/pkg/FreeBSD.conf
Then:
pkg update pkg upgrade freebsd-update fetch freebsd-update install portsnap fetch portsnap extract portsnap update
Intel ucode
pkg install devcpu-data
/boot/loader.conf.local cpu_microcode_load="YES" cpu_microcode_name="/boot/firmware/intel-ucode.bin"
Firewall
/etc/rc.conf pf_enable="YES" pf_rules="/etc/pf.conf"
/etc/pf.conf block in all pass out all keep state
Audio
The default audio needs to be enabled and the port output needs to be switched. This will change it to line out on the back.
/etc/sysctl.conf hw.snd.default_unit=3 dev.hdaa.0.config="ovref" dev.hdaa.0.gpio_config="0=set 1=set" dev.hdaa.0.nid21_config="as=4 seq=15"
/etc/rc.conf sndiod_enable="YES"
Video
I was able to get the video working by installing the old nVidia driver. The 304 release worked. "Nvidia GeForce 7300GT"
pkg install nvidia-driver-304
/etc/rc.conf linux_enable="YES" linux64_enable="YES" nvidia_load="YES" nvidia-modeset_load="yes" linux_load="YES"
/boot/loader.conf.local linux_enable="YES" linux64_enable="YES" nvidia_load="YES" nvidia-modeset_load="yes" linux_load="YES" agp_load="YES"
The video driver does act wonky in a tty though. It will flash green and pink with the text going garbled and I noticed the text is still very large. Changing your vt will resolve this issue.
/boot/loader.conf.local kern.vty=sc
Kernel
You will get tons of kernel related errors. Apparently it has something to do with the smart battery. You can disable them.
/boot/loader.conf.local debug.acpi.disabled="smbat"
The Apple System Management Controller (SMC) is not enabled by default. You have two options:
Option 1) You can compile a kernel with asmc support built in. To do this, you will need to learn how to build a kernel and may need to download this kernel patch and put it in /usr/src/sys/dev/asmc/ [This patch was merged into the source in 2018]
You want to make a copy (cp) of the GENERIC kernel config, for example, cp -r GENERIC MAC in /usr/src/sys/amd64/conf/ and then "make buildkernel KERNCONF=MAC" when compiling. Add the following lines to your kernel MAC.conf file. device coretemp device asmc device smb device smbus device smbios device cpuctl
Option 2) If the asmc kernel module already includes the patch, then as root you can simply dynamically load the asmc and other kernel modules from the command line with:
kldload coretemp kldload asmc kldload smb kldload smbus kldload smbios kldload cpuctl
To ensure these modules are dynamically loaded on subsequent boots, add these lines to the /boot/loader.conf.local file:
coretemp_load="YES" asmc_load="YES" smb_load="YES" smbus_load="YES" smbios_load="YES" cpuctl_load="YES"
Time
The clock is horribly off.
tzsetup Select Yes. Scroll down to bottom and select UTC.
That should be about it.
The FreeBSD Foundation has a great tutorial on installing a working desktop environment as well.